【PAT甲级 - C++题解】1039 Course List for Student

简介: 【PAT甲级 - C++题解】1039 Course List for Student

1039 Course List for Student


Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N**i (≤200) are given in a line. Then in the next line, N**i student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:


For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0


题意


第一行包含两个整数 N  和 K ,分别表示需要查询的学生数量以及课程数量。


接下来包含 K个课程的具体报名信息。


每个课程信息的第一行包含两个整数 i 和N i,分别表示该课程的编号(所有课程编号从 1 到 K )以及报课人数。


第二行包含 N i 个学生姓名,学生姓名由三个大写字母和一个数字组成。


最后一行包含 N  个学生姓名,表示要查询的学生名单。


输出共 N 行,每行输出一个学生的姓名,报课总数,以及所有报名的课程的编号(按照升序排列)。


学生信息的输出顺序应与查询名单中的顺序一致。

思路


用一个哈希表存储每个学生要选的课程是什么,key 是学生姓名,value 是该学生所选课程的编号,用 set 来存储,它可以自动从小到大进行排序,这样到时候输出的时候就不用再去排序了。

边输入学生的信息边输出该学生的信息,因为刚才每个课程选课学生的信息已经保存起来了,所以现在就按照给定学生的名单去输出对应学生的选课信息。注意输出的时候要先输出姓名,然后输出选课数量,最后再依次按照从小到大输出课程编号。

代码

#include<bits/stdc++.h>
using namespace std;
unordered_map<string, set<int>> res;
int main()
{
    int n, m;
    cin >> n >> m;
    //输入学生信息
    for (int i = 1; i <= m; i++)
    {
        int index, k;
        cin >> index >> k;
        for (int i = 0; i < k; i++)
        {
            string name;
            cin >> name;
            res[name].insert(index);
        }
    }
    //输出每个学生的选课信息
    for (int i = 0; i < n; i++)
    {
        string name;
        cin >> name;
        cout << name;
        if (res.count(name))  //判断该学生是否有选课
        {
            cout << " " << res[name].size();
            for (auto& s : res[name])
                cout << " " << s;
            cout << endl;
        }
        else puts(" 0");
    }
    return 0;
}


目录
相关文章
|
7天前
|
编译器 C语言 C++
【c++丨STL】list模拟实现(附源码)
本文介绍了如何模拟实现C++中的`list`容器。`list`底层采用双向带头循环链表结构,相较于`vector`和`string`更为复杂。文章首先回顾了`list`的基本结构和常用接口,然后详细讲解了节点、迭代器及容器的实现过程。 最终,通过这些步骤,我们成功模拟实现了`list`容器的功能。文章最后提供了完整的代码实现,并简要总结了实现过程中的关键点。 如果你对双向链表或`list`的底层实现感兴趣,建议先掌握相关基础知识后再阅读本文,以便更好地理解内容。
15 1
|
19天前
|
算法 C语言 C++
【c++丨STL】list的使用
本文介绍了STL容器`list`的使用方法及其主要功能。`list`是一种双向链表结构,适用于频繁的插入和删除操作。文章详细讲解了`list`的构造函数、析构函数、赋值重载、迭代器、容量接口、元素访问接口、增删查改操作以及一些特有的操作接口如`splice`、`remove_if`、`unique`、`merge`、`sort`和`reverse`。通过示例代码,读者可以更好地理解如何使用这些接口。最后,作者总结了`list`的特点和适用场景,并预告了后续关于`list`模拟实现的文章。
34 7
|
28天前
|
存储 编译器 C++
C++ initializer_list&&类型推导
在 C++ 中,`initializer_list` 提供了一种方便的方式来初始化容器和传递参数,而右值引用则是实现高效资源管理和移动语义的关键特性。尽管在实际应用中 `initializer_list&&` 并不常见,但理解其类型推导和使用方式有助于深入掌握现代 C++ 的高级特性。
20 4
|
3月前
|
存储 搜索推荐 C++
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器2
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器
69 2
|
3月前
|
存储 算法 C++
【C++打怪之路Lv10】-- list
【C++打怪之路Lv10】-- list
24 1
|
3月前
|
存储 C++ 容器
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器1
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器
76 5
|
3月前
|
存储 编译器 C++
【C++篇】揭开 C++ STL list 容器的神秘面纱:从底层设计到高效应用的全景解析(附源码)
【C++篇】揭开 C++ STL list 容器的神秘面纱:从底层设计到高效应用的全景解析(附源码)
85 2
|
3月前
|
存储 缓存 C++
C++番外篇——list与vector的比较
C++番外篇——list与vector的比较
29 0
|
3月前
|
C++
C++番外篇——list的实现
C++番外篇——list的实现
25 0
|
3月前
|
存储 C++ 容器
C++入门9——list的使用
C++入门9——list的使用
23 0