【PAT甲级 - C++题解】1019 General Palindromic Number

简介: 【PAT甲级 - C++题解】1019 General Palindromic Number

1019 General Palindromic Number


A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.


Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a**i as ∑i=0k(aib**i). Here, as usual, 0≤a**i<b for all i and a**k is non-zero. Then N is palindromic if and only if a**i=a**k−i for all i. Zero is written 0 in any base and is also palindromic by definition.


Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:


Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:


For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “a**k a**k−1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2
• 1

Sample Output 1:

Yes
1 1 0 1 1


Sample Input 2:

121 5
• 1

Sample Output 2:

No
4 4 1


题意


这道题给定一个十进制数 n 和进制 b ,需要我们将 n 转换成 b 进制,然后判断 b 进制下该数是否是回文数,最后还要输出转换成 b 进制的数。


思路

  1. 先用一个 vector 容器存转换成 b 进制的每一位数。
  2. 判断 b 进制下的数是否为回文数。
  3. 输出转换成 b 进制的数,注意这里需要从后往前输出,因为存数的时候下标为 0 的位置存的是最低位。


代码

#include<bits/stdc++.h>
using namespace std;
//判断是否是回文数
bool check(vector<int> x)
{
    for (int i = 0, j = x.size() - 1; i < j; i++, j--)
        if (x[i] != x[j])
            return false;
    return true;
}
int main()
{
    int n, b;
    cin >> n >> b;
    //将十进制数转船成b进制
    vector<int> ans;
    if (n == 0)    ans.push_back(0);
    while (n)
    {
        ans.push_back(n % b);
        n /= b;
    }
    //判断b进制下该数是否是回文数
    if (check(ans))  puts("Yes");
    else puts("No");
    //输出b进制下的数
    cout << ans[ans.size() - 1];
    for (int i = ans.size() - 2; i >= 0; i--)
        cout << " " << ans[i];
    return 0;
}


目录
相关文章
|
11月前
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
35 0
|
11月前
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
55 0
|
11月前
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
49 0
|
11月前
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
48 0
|
11月前
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
58 0
|
1天前
|
编译器 C++
【C++】一文全解四种经典 [ 特殊类 ]的设计
【C++】一文全解四种经典 [ 特殊类 ]的设计
|
2天前
|
编译器 C语言 C++
c++初阶------类和对象(六大默认构造函数的揭破)-3
c++初阶------类和对象(六大默认构造函数的揭破)
|
2天前
|
编译器 C语言 C++
c++初阶------类和对象(六大默认构造函数的揭破)-2
c++初阶------类和对象(六大默认构造函数的揭破)
|
2天前
|
存储 编译器 C语言
c++初阶------类和对象(六大默认构造函数的揭破)-1
c++初阶------类和对象(六大默认构造函数的揭破)
|
2天前
|
存储 编译器 C语言
c++初阶-------类和对象-2
c++初阶-------类和对象