【PAT甲级 - C++题解】1060 Are They Equal

简介: 【PAT甲级 - C++题解】1060 Are They Equal

1060 Are They Equal


If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.


Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.


Output Specification:


For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.


Note: Simple chopping is assumed without rounding.


Sample Input 1:

3 12300 12358.9
• 1

Sample Output 1:

YES 0.123*10^5


Sample Input 2:

3 120 128
• 1

Sample Output 2:

NO 0.120*10^3 0.128*10^3


思路

这道题主要难点就在于将给定的浮点数转换成 0. x ∗ 1 0 y 0.x*10^y0.x∗10

y

 的形式,我们这里来讲如何处理字符串:


先找到 . ,如果是整数需要人为在后面加上一个 . ,因为我们要得到 . 的位置 k kk ,用于分隔两边的数字。

将 . 两边的数字即字符串合并,然后去除多余的前缀 0 00 。

判断去除完 0 00 后字符串是否为空,要将 k kk 也置 0 00 ,防止其越界。

判断有效位数 n nn 与字符串的长度的大小,如果字符串位数大于有效位数则要进行截断,反之补 0 00 。

返回时,注意字符串的格式。

代码

#include<bits/stdc++.h>
using namespace std;
int n;
string a, b;
string change(string str, int n)
{
    //找到'.',如果没有则加在后面并且找到其所在位置
    int k = str.find(".");
    if (k == -1)   str += ".", k = str.find(".");
    //合并'.'两边的字符串,并去除前缀0
    string s = str.substr(0, k) + str.substr(k + 1);
    while (s.size() && s[0] == '0')  s = s.substr(1), k--;
    if (s.empty())   k = 0;    //字符串为空k也要置0
    if (s.size() > n)  s = s.substr(0, n);    //字符串长度大于有效位要截断
    else s += string(n - s.size(), '0');       //反之要补0
    return "0." + s + "*10^" + to_string(k);
}
int main()
{
    cin >> n >> a >> b;
    a = change(a, n);
    b = change(b, n);
    if (a == b)    cout << "YES " << a << endl;
    else cout << "NO " << a << " " << b << endl;
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
78 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
79 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
135 0
|
9天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
36 4
|
10天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
33 4
|
1月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
27 4