npm WARN deprecated socks@1.1.10: If using 2.x branch, please upgrade to at least 2.1.6

简介: npm WARN deprecated socks@1.1.10: If using 2.x branch, please upgrade to at least 2.1.6

cnpm安装的时候出现的一个问题。


使用npm install cnpm -g --registry=https://registry.npm.taobao.org命令的时候就会出现下图中的WARN。


20180516173755774.png


接下来就该耐心的看一看这个WARN,大概在说版本问题吧?图片上的倒数第二行可能就是给你推荐的版本。


换个命令试一试,这次使用npm install npm@5.3.0   @后是你对应的npm版本号 ,可以通过npm -v 查看


使用cnpm -v 命令查看一下是否安装成功,如下图:


20180516175425908.png

相关文章
|
10月前
npm WARN deprecated core-js@2.6.12 core-js@<3.3 is no longer maintained and not recommended for usa
npm WARN deprecated core-js@2.6.12 core-js@<3.3 is no longer maintained and not recommended for usa
234 0
|
1月前
|
JavaScript
报错:npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
报错:npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
|
6月前
Error:npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\XX\package.json‘son‘
Error:npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\XX\package.json‘son‘
|
7月前
|
JavaScript 前端开发 测试技术
npm run dev启动报错:TypeError: Cannot read property 'upgrade' of undefined
npm run dev启动报错:TypeError: Cannot read property 'upgrade' of undefined
136 0
|
10月前
|
JSON 数据格式
NPM Error Unexpected token < in JSON at position 0 while parsing near ‘<!DOCTYP
NPM Error Unexpected token < in JSON at position 0 while parsing near ‘<!DOCTYP
337 0
npm WARN lifecycle yarn@1.22.19~preinstall: cannot run in wd %s %s
npm WARN lifecycle yarn@1.22.19~preinstall: cannot run in wd %s %s
837 0
|
前端开发
前端项目实战2-npm WARN config global --global, --local are deprecated. Use `–location解决方案
前端项目实战2-npm WARN config global --global, --local are deprecated. Use `–location解决方案
740 0
|
1月前
|
网络安全 计算机视觉
【node】 npm install 报错:code 128
【node】 npm install 报错:code 128
56 1
|
1月前
|
JavaScript Linux 数据安全/隐私保护
node内网安装npm私服以及依赖包上传发布verdaccio
node内网安装npm私服以及依赖包上传发布verdaccio
193 1
|
1月前
|
JavaScript
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
21 0

热门文章

最新文章

推荐镜像

更多