《CCNP TSHOOT 300-135认证考试指南》——6.5节SVI故障工单-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

《CCNP TSHOOT 300-135认证考试指南》——6.5节SVI故障工单

简介:

本节书摘来自异步社区《CCNP TSHOOT 300-135认证考试指南》一书中的第6章,第6.5节SVI故障工单,作者 【加】Raymond Lacoste , 【美】Kevin Wallace,更多章节内容可以访问云栖社区“异步社区”公众号查看

6.5 SVI故障工单
CCNP TSHOOT 300-135认证考试指南
本节将给出与本章前面讨论过的主题相关的故障工单,目的是通过这些故障工单让读者真正了解现实世界或考试环境中的故障检测与排除流程。本节的所有故障工单都以图6-5所示的拓扑结构为例。


dde9d6bf113fdfbc5a8da03289045ba7504acb89

6.5.1 故障工单6-3
故障问题:PC1无法访问PC2的资源。

首先验证该故障工单提到的故障问题。例6-19证实了PC1无法访问PC2的资源,这是因为ping测试失败。


93382ed9db6418d73222e4553703babd2752a378

接下来验证SW2在正确的接口上学到了PC1的MAC地址并且关联到正确的VLAN上。从例6-22显示的show mac address-table dynamic命令输出结果可以看出,PC1的MAC地址(0800:275d:06d6)与Fa0/1及VLAN 10相关联。


c0074e0b8bb0945d61742014029a46d2b3d2cea1

导致SVI协议处于down状态的原因有哪些呢?

交换机上不存在与该SVI对应的VLAN;
SVI被管理性关闭;
对于该VLAN来说,没有任何一个交换端口(接入或中继)为up/up且处于生成树转发状态。
中继接口无法学到MAC地址的原因有哪些呢?

中继的封装方式、模式以及本征VLAN不匹配;
中继以手工或动态方式过滤了该VLAN的流量,致使该VLAN的生成树处于非转发状态;
交换机上不存在该VLAN。
对比上述两个原因列表,有哪些相同点呢?

VLAN不存在;
没有任何一个接口上的VLAN处于生成树转发状态。
在SW1上运行show interfaces trunk命令,可以看到Gig1/0/1接口上每个VLAN的生成树转发状态。例6-25显示了SW1的show interfaces trunk命令输出结果,并以阴影方式显示了SW1的接口Gig1/0/1没有处于VLAN 10的生成树转发状态,只有VLAN 1和VLAN 20处于生成树转发状态。进一步分析输出结果可以发现,VLAN 10根本就不在管理域中的活跃VLAN列表中,因而表明SW1上不存在VLAN 10。


984bd9dcda5424397b612d0caed1bce1944caa24

回顾SW1的show vlan brief命令输出结果,可以证实VLAN确实不存在(如例6-26所示)。为了解决该问题,可以在全局配置模式下利用vlan 10命令创建该VLAN。


7c7d2bdc71ce056adf18b6f791de57a85a4bb5d7


593920ad1f44d836baa4975cb2a56757387f08ca

6.5.2 故障工单6-4
故障问题:PC1无法访问PC2的资源。

首先验证该故障工单提到的故障问题,例6-31证实了PC1无法访问PC2的资源,这是因为ping测试失败。接下来证实PC1可以到达默认网关(如例6-32所示),这是因为ping测试成功,表明PC1与默认网关之间没有故障。接下来验证PC1可以到达VLAN 20的默认网关(10.1.1.65)。例6-33证实了PC1可以到达VLAN 20的默认网关,这是因为ping测试成功。


aca03b9e1c26f94769eeb7fea176cca2bb97d13d

由于所有的ping测试均成功,因而表明SW1与PC2之间可能存在故障,可以从SW1向PC2发起ping测试来加以验证。例6-34显示了在SW1上运行ping 10.1.1.74命令的输出结果,可以看出ping测试成功,从而否定了SW1与PC2之间存在故障的假设。


f757ea97a3d18d7fb6f873aa16486d73558ab24e

简而言之,PC1可以ping通SVI 10,PC2可以ping通SVI 20,那么可以推断
接下来利用show ip route命令检查SW1的路由表。show ip route命令的输出结果(如例6-37所示)看起来根本就不像路由表,因而SW1无法路由流量,只能响应发送到本地接口的ping。大家应该能够通过例6-37的输出结果找到问题的解决方案。问题在于SW1上没有启用IP路由。三层交换机默认不启用IP路由,如果要启用IP路由,需要在全局配置模式下运行ip routing命令。


336e4bc300197a29e21604c2c4e4d9ef306a546a

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: