Dungeon Master(三维bfs)java

简介: The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

题意:



You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?


Input



The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.


Output



Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!


Sample Input



3 4 5

S…

.###.

.##…

###.#


##.##

##…


#.###

####E


1 3 3

S##

#E#


0 0 0


Sample Output



Escaped in 11 minute(s).

Trapped!


以前都是二位搜索,三维bfs就有上下左右前后六个位置,其他处理没区别。


import java.util.ArrayDeque;
import java.util.Comparator;
import java.util.PriorityQueue;
import java.util.Queue;
import java.util.Scanner;
/*
 *  0 1 1 0
 *  0 0 0 0
 *  0 0 0 0
 *  0 1 1 0
 */
public class testB {
  static int xstart=0;static int ystart=0;static int hstart=0;
  static int xend=0;static int yend=0;static int hend=0;
  static int x1[]= {0,1,0,0,-1,0};//上下左右 前后
  static int y1[]= {1,0,0,-1,0,0};
  static int z1[]= {0,0,1,0,0,-1};
  public static void main(String[] args) {
    // TODO 自动生成的方法存根
    Scanner sc=new Scanner(System.in);
    while(sc.hasNext())
    {
      int l=sc.nextInt();//lever层数  h
      int r=sc.nextInt();//行  x
      int c=sc.nextInt();//列  y
      if(l==0&&r==0&&c==0)break;
      char map[][][]=new char[l][r][c];
      for(int i=0;i<l;i++)
      {
        for(int j=0;j<r;j++)
        {
          map[i][j]=sc.next().toCharArray();
        }
//        sc.next();
      }
      for(int i=0;i<l;i++)
      {
        for(int j=0;j<r;j++)
        {
          for(int k=0;k<c;k++)
          {
            if(map[i][j][k]=='S')
            {
              xstart=j;ystart=k;hstart=i;
            }
          }
         // System.out.println();
        }
        //System.out.println("    ");
      }
      boolean jud[][][]=new boolean[l][r][c];
      Queue<node>q1=new ArrayDeque<node>();
      q1.add(new node(xstart, ystart, hstart,0));
      boolean b=false;int x,y,z=0;
      jud[hstart][xstart][ystart]=true;
      while(!q1.isEmpty())
      {
        node point=q1.poll();
         x=point.x;y=point.y; z=point.h;
        for(int i=0;i<6;i++)
        {
          if(x+x1[i]<r&&x+x1[i]>=0&&y+y1[i]>=0&&y+y1[i]<c&&z+z1[i]>=0&&z+z1[i]<l)//没有越界
          {
            if(map[z+z1[i]][x+x1[i]][y+y1[i]]=='.'&&!jud[z+z1[i]][x+x1[i]][y+y1[i]])
            {
              q1.add(new node(x+x1[i], y+y1[i], z+z1[i], point.minitu+1));
              jud[z+z1[i]][x+x1[i]][y+y1[i]]=true;
            }
            else if(map[z+z1[i]][x+x1[i]][y+y1[i]]=='E')
            {
              System.out.println("Escaped in "+(point.minitu+1)+" minute(s).");
              b=true;
              break;
            }
          }
        }
        if(b)break;
      }
      if(!b)
      {
        System.out.println("Trapped!");
      }
    }
  } 
  static Comparator<node>com=new Comparator<node>() {
    public int compare(node o1, node o2) {
      // TODO 自动生成的方法存根
      return (int)(o1.minitu-o2.minitu);
    }
  };
}
class node
  {
    int x;int y;int h;
    int minitu;
    public node(int x,int y,int h, int minitu)
    {
      this.x=x;this.y=y;this.h=h;this.minitu=minitu;
    }
  }
目录
相关文章
|
6月前
|
Java 开发工具 流计算
flink最新master代码编译出现Java Runtime Environment 问题
在尝试编译Flink源码时遇到Java运行时环境致命错误:EXCEPTION_ACCESS_VIOLATION。问题出现在JVM.dll+0x88212。使用的是Java 11.0.28和Java HotSpot(TM) 64-Bit Server VM。系统为Windows客户端,没有生成核心dump文件。错误日志保存在hs_err_pid39364.log和replay_pid39364.log。要解决这个问题,建议检查JDK版本兼容性,更新JDK或参照错误报告文件提交Bug至http://bugreport.java.com/bugreport/crash.jsp。
【Java每日一题,BFS】Catch That Cow
【Java每日一题,BFS】Catch That Cow
|
5月前
|
存储 算法 Java
Java中,树与图的算法涉及二叉树的前序、中序、后序遍历以及DFS和BFS搜索。
【6月更文挑战第21天】Java中,树与图的算法涉及二叉树的前序、中序、后序遍历以及DFS和BFS搜索。二叉树遍历通过访问根、左、右子节点实现。DFS采用递归遍历图的节点,而BFS利用队列按层次访问。以下是简化的代码片段:[Java代码略]
45 4
|
2月前
|
缓存 Java Linux
java操作hbase报错:KeeperErrorCode=NoNode for /hbase-unsecure/master
java操作hbase报错:KeeperErrorCode=NoNode for /hbase-unsecure/master
124 2
|
6月前
|
算法 Java
BFS(广度搜索|宽度搜索)无向图遍历(JAVA手把手深入解析)
BFS(广度搜索|宽度搜索)无向图遍历(JAVA手把手深入解析)
136 0
|
Java
数据结构(11)图的遍历,DFS、BFS的JAVA实现
11.1.图的遍历 图的遍历,即将图内所有顶点都访问一遍。 有两种遍历方式: BFS DFS 以下图的遍历为例:
92 0
|
算法 Java
二叉树最大宽度(java 算法 bfs)
二叉树最大宽度(java 算法 bfs)
160 0
二叉树最大宽度(java 算法 bfs)
|
人工智能 Java BI
力扣207:课程表(Java拓扑排序:bfs+dfs)
力扣207:课程表(Java拓扑排序:bfs+dfs)
132 0
力扣200:岛屿数量(Java dfs+bfs)
给你一个由 '1'(陆地)和 '0'(水)组成的的二维网格,请你计算网格中岛屿的数量。 岛屿总是被水包围,并且每座岛屿只能由水平方向和/或竖直方向上相邻的陆地连接形成。
122 0
|
算法 Java
hdu1181变形课dfs/bfs/并查集三种解法(java)
呃…变形课上Harry碰到了一点小麻烦,因为他并不像Hermione那样能够记住所有的咒语而随意的将一个棒球变成刺猬什么的,但是他发现了变形咒语的一个统一规律:如果咒语是以a开头b结尾的一个单词,那么它的作用就恰好是使A物体变成B物体. Harry已经将他所会的所有咒语都列成了一个表,他想让你帮忙计算一下他是否能完成老师的作业,将一个B(ball)变成一个M(Mouse),你知道,如果他自己不能完成的话,他就只好向Hermione请教,并且被迫听一大堆好好学习的道理.
184 0