PAT (Advanced Level) Practice 1042 Shuffling Machine (20 分)

简介: PAT (Advanced Level) Practice 1042 Shuffling Machine (20 分)

题目描述


Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.


The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:


S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2


where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.


Input Specification:


Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.


Output Specification:


For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.


Sample Input:


2

36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47


Sample Output:


S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


代码


/

#include<bits/stdc++.h>
using namespace std;
int main()
{
  ios::sync_with_stdio(false);
  cin.tie(0);
  int n;
  scanf("%d",&n);
  int start[60];
  int end[60];
  int next[60];
  for(int i=1;i<=54;i++)
  {
    start[i]=i;
  }
  for(int i=1;i<=54;i++)
  {
    scanf("%d",&next[i]);
  }
  for(int i=0;i<n;i++)
  {
    for(int j=1;j<=54;j++)
    {
      end[next[j]]=start[j];
    }
    for(int k=1;k<=54;k++)
    {
      start[k]=end[k];
    }
  }
  char mp[5]={'S','H','C','D','J'};
  for(int i=1;i<=54;i++)
  {
    if(i!=1)
    {
      printf(" ");
    }
    printf("%c",mp[(start[i]-1)/13]);
    printf("%d",(start[i]-1)%13+1);
  }
}

分析


使用start[60],end[60]数组,start数组用于记录刚开始的状态,end数组由于记录变化之后的状态,还有一个next[60]数组,用于存放变换规则,用笔在纸上进行模拟,假设start数组初始值为{1,2,3,4,5},next数组的变换规则为{5,4,3,2,1},那么end数组变为{5,4,3,2,1},代码可以写为 end[next[i]]=start[i], 加入start[4]=48,next[4]=10,就是将值48从第四个位置变换到第十个位置,最后的结果是end[10]=48,循环一遍之后end数组的信息得到的就是next规则的数组,最后将end数组的信息全部复制的start数组之后,然后按要求进行循环。最后得到结果之后,将数组内容转换成字母+下标格式进行输出即可。


注意


最后转换字符输出要注意


要注意输出格式


/

for(int i=1;i<=54;i++)
  {
    if(i!=1)
    {
      printf(" ");
    }
    printf("%c",mp[(start[i]-1)/13]);
    printf("%d",(start[i]-1)%13+1);
  }
相关文章
PAT (Advanced Level) Practice:1~3题
​ ✨欢迎您的订阅✨ PAT乙级专栏(更新完毕): 👉🏻【Basic Level】👈🏻 PAT甲级专栏(更新ing): 👉🏻【Advanced Level】👈🏻 ​
PAT (Advanced Level) Practice:1~3题
PAT (Advanced Level) Practice - 1147 Heaps(30 分)
PAT (Advanced Level) Practice - 1147 Heaps(30 分)
96 0
PAT (Advanced Level) Practice - 1095 Cars on Campus(30 分)
PAT (Advanced Level) Practice - 1095 Cars on Campus(30 分)
111 0
PAT (Advanced Level) Practice - 1062 Talent and Virtue(25 分)
PAT (Advanced Level) Practice - 1062 Talent and Virtue(25 分)
123 0
PAT (Advanced Level) Practice - 1129 Recommendation System(25 分)
PAT (Advanced Level) Practice - 1129 Recommendation System(25 分)
78 0
PAT (Advanced Level) Practice - 1022 Digital Library(30 分)
PAT (Advanced Level) Practice - 1022 Digital Library(30 分)
101 0
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
96 0
|
存储
PAT (Advanced Level) Practice - 1126 Eulerian Path(25 分)
PAT (Advanced Level) Practice - 1126 Eulerian Path(25 分)
113 0
PAT (Advanced Level) Practice - 1112 Stucked Keyboard(20 分)
PAT (Advanced Level) Practice - 1112 Stucked Keyboard(20 分)
105 0
PAT (Advanced Level) Practice - 1018 Public Bike Management(30 分)
PAT (Advanced Level) Practice - 1018 Public Bike Management(30 分)
177 0