机房收费系统vb.net之打包与部署(二)-阿里云开发者社区

开发者社区> 开发与运维> 正文

机房收费系统vb.net之打包与部署(二)

简介:

             紧接着上篇博客的打包和部署,下面说一下我在XP系统和.net framework2.0平台发布系统的解决办法,对于.net framework2.0的情况,因为大家知道如果用visual studio2013的话,最低的运行平台是2.0但是的代码是在4.5的平台下实现的,要是转换过去,会出很多错误,见下图:

           

          生成后的效果就是会出现很多的错误:

           

           原因就是我之前 敲代码的目标框架是默认的4.5,而改成2.0后差异太大,有很多内部编译都发生了变化,因此这种方法是不可以的,下面是我解决这个问题的一个说了有些投机取巧的方法吧:

            首先,将源码中所有项目的目标框架改为4.0,原因是从4.5--4.0不会错误,这两种框架之间编译的差异小,如下图:

            

            其次,从网上查资料得知,XP系统最高可以运行.net framework4.0,于是我就把XP系统中的2.0版本用4.0版本替换了,但是对于这两个版本的差别,我还是不很清楚,这是我从网上查到的一些资料,和大家分享一下:

            .net framework2.0:无需部署即可轻松使用应用程序,· 为 Windows XP 用户使用 Windows Vista 做好准备

            .net framework4.0主要是增加了并行支持,可是我差了资料,还是不知道什么叫并行支持,等待高人解答~

            可是我以为这样的操作就行了,于是兴致勃勃到5楼安装,没想到一点快捷方式,它居然又一次打击我~”(null)不是有效的win32应用程序“,心寒~我花了两天解决的问题居然又冒出了新问题,于是又开始了取经之路,查资料,原来是因为我当初编译的程序是64位的,而XP是32位系统,于是,新的问题,新的发现,我开始从vs2013下手,重新生成,下面是我对它的操作:

            第一步:选择配置管理器             

              第二步:如图,选择”新建“

              

              点击“从此处复制设置”--选择“86”--点击“确定”

              

              接着在配置管理器--“活动解决方案平台”--“86”,如下图:

                     

                    接下来在这个XP系统上就可以正常运行啦!希望和大家交流!

版权声明:本文首发在云栖社区,遵循云栖社区版权声明:本文内容由互联网用户自发贡献,版权归用户作者所有,云栖社区不为本文内容承担相关法律责任。云栖社区已升级为阿里云开发者社区。如果您发现本文中有涉嫌抄袭的内容,欢迎发送邮件至:developer2020@service.aliyun.com 进行举报,并提供相关证据,一经查实,阿里云开发者社区将协助删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章