HDOJ 1064Financial Management

简介: HDOJ 1064Financial Management

Problem Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.


Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.


Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.


Sample Input

100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

1.75


Sample Output

$1581.42


#include<stdio.h>
int main()
{
    int i;
    double a,s;
    s=0;
    for(i=1;i<=12;i++)
     {
       scanf("%lf",&a);
       s+=a;
     }
    printf("$%.2lf\n",s/12);
    return 0;
}


目录
相关文章
|
4月前
|
机器学习/深度学习 JSON 网络协议
Nostr with NIP-05 Verification Guide
该文章是一个关于Nostr协议中NIP-05验证的指南,解释了NIP-05允许用户将公钥映射到基于DNS的可读标识符上,并提供了如何在个人域名上设置`nostr.json`文件或使用现有NIP-05服务来完成验证的步骤。
27 3
Nostr with NIP-05 Verification Guide
|
传感器 监控 自动驾驶
我所理解的loT
“物联网(The Internet of Things,简称IOT)是指通过各种信息传感器、射频识别技术、全球定位系统、红外线感应器、激光扫描器等各种装置与技术,实时采集任何需要监控、 连接、互动的物体或过程,采集其声、光、热、电、力学、化 学、生物、位置等各种需要的信息,通过各类可能的网络接入,实现物与物、物与人的泛在连接,实现对物品和过程的智能化感知、识别和管理。物联网是一个基于互联网,传统电信网等的信息承载体,它让所有能够被独立寻址的普通物理对象形成互联互通的网络。”----------《什么是物联网》
我所理解的loT
Choosing Teams
Choosing Teams
130 0
Choosing Teams
|
物联网 智能硬件
我理解的lot
物联网的蓬勃发展,使商业与社会的交织、融合超越以往任何时代,进入了可持续发展的物联网生态时代。
我理解的lot
HDOJ 1064 Financial Management
HDOJ 1064 Financial Management
85 0
|
存储 传感器 数据采集
我对lot的理解
对lot的了解
1042 0
|
CDN
Building an Industry Information Website
Object Storage Server (OSS) is a massive, secure, low-cost and highly reliable distributed storage service offered by Alibaba Cloud.
1572 0
Building an Industry Information Website
6 Major Changes in Science and Technology Reshaping the Retail Industry
As the transformation of the retail industry deepens, consumers are now at the center of the entire industry ecosystem.
3822 0
6 Major Changes in Science and Technology Reshaping the Retail Industry
Uptime And Monitoring Strategies For Cloud-Based E-Commerce Applications/Websites
In order to keep your e-commerce site functioning properly, you need to take positive steps to monitor both its performance and functionality.
1517 0
|
安全
How Important is Data Security for the Financial Industry?
90% of financial companies worldwide think they have data security risks. What security problems do financial industry users typically encounter?
2021 0