最大子列和问题

简介: 版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sinat_32502811/article/details/77850560 01-复杂度1 最大子列和问题(20 分)给定K个整数组成的序列{ N ​1 ​​ , N ​2 ​​ , …, N ​K ​​ },“连续子列”被定义为{ N ​i ​​ , N ​i+1 ​​ , …, N ​j ​​ },其中 1≤i≤j≤K。
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sinat_32502811/article/details/77850560

01-复杂度1 最大子列和问题(20 分)

给定K个整数组成的序列{ N
​1
​​ , N
​2
​​ , …, N
​K
​​ },“连续子列”被定义为{ N
​i
​​ , N
​i+1
​​ , …, N
​j
​​ },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。
本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:
数据1:与样例等价,测试基本正确性;
数据2:102个随机整数;
数据3:103个随机整数;
数据4:104个随机整数;
数据5:105个随机整数;
输入格式:

输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。
输出格式:

在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。
输入样例:

6
-2 11 -4 13 -5 -2
输出样例:

20

#include <stdio.h>

int MaxSubseqSum1(int A[], int N);
int MaxSubseqSum2(int A[], int N);//分治法
int MaxSubseqSum3(int A[], int N);//动态规划

int main() {
    int N;
    int A[100000];
    int Max= 0;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
            scanf("%d", &A[i]);
    }
    Max = MaxSubseqSum3(A, N);
    if(Max < 0) Max = 0;
    printf("%d\n",Max);
    return 0;
}

int MaxSubseqSum1(int A[], int N) {
    int Sum, MaxSum;
    int i, j;
    MaxSum = 0;
    for (i = 0; i < N; i++) {
        Sum = 0;
        for (j = i; j < N; j++) {
            Sum += A[j];
            if (Sum > MaxSum) {
                MaxSum = Sum;
            }
        }
    }
    if (MaxSum < 0)
        MaxSum = 0;
    return MaxSum;
}

int Max3(int A, int B, int C) {
  return A > B ? A > C ? A : C : B > C ? B : C;
}
int DivideAndConquer(int List[], int left, int right) {
    int MaxLeftSum, MaxRightSum;
    int MaxLeftBorderSum, MaxRightBorderSum;
    int LeftBorderSum, RightBorderSum;
    int center, i;
    if (left == right) {
        if (List[left] > 0) return List[left];
        else return 0;
    }
    center = (left + right) / 2;
    MaxLeftSum = DivideAndConquer(List, left, center);
    MaxRightSum = DivideAndConquer(List, center + 1, right);
    MaxLeftBorderSum = 0;
    LeftBorderSum = 0;
    for (i = center; i >= left; i--) {
        LeftBorderSum += List[i];
        if (LeftBorderSum > MaxLeftBorderSum)
            MaxLeftBorderSum = LeftBorderSum;
    }
    MaxRightBorderSum = 0;
    RightBorderSum = 0;
    for (i = center + 1; i <= right; i++) {
        RightBorderSum += List[i];
        if (RightBorderSum > MaxRightBorderSum)
            MaxRightBorderSum = RightBorderSum;
    }
    return Max3(MaxLeftBorderSum + MaxRightBorderSum, MaxLeftSum, MaxRightSum);
}
int MaxSubseqSum2(int A[], int N) {
    return DivideAndConquer(A, 0, N - 1);
}
int MaxSubseqSum3(int A[], int N) {
    int ThisSum, MaxSum;
    int i;
    ThisSum = MaxSum = 0;
    for (i = 0; i < N; i++) {
        ThisSum += A[i];
        if (ThisSum > MaxSum)
            MaxSum = ThisSum;
        else if(ThisSum < 0)
        {
            ThisSum = 0;
        }
    }
    return MaxSum;
}

主要是写了三个算法。比较重要的是第二个分治法的理解和第三个动态规划的理解。二者的时间复杂度分别为O(nlogn)和O(n)

01-复杂度2 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N
​1 , N2, …, NK}. A continuous subsequence is defined to be { N
​i​​ , Ni+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4

#include <stdio.h>
#include <time.h>


int MaxSubseqSum3(int A[], int N);
int START;
int END;

int main() {
    int N;
    int A[10000];
    int j = 0;
    int Max,a,b;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
        scanf("%d", &A[i]);
    }
    Max = MaxSubseqSum3(A, N);
    a = A[START];
    b = A[END];
    printf("%d %d %d\n", Max,a,b);
    return 0;
}
int MaxSubseqSum3(int A[], int N) {
    int ThisSum = 0;
    int MaxSum = -1;
    int i;
    int start = 0;int starttemp = 0;
    int end = N-1 ;int endtemp = 0;
    for (i = 0; i < N; i++) {
        ThisSum += A[i];

        if (ThisSum > MaxSum) {
            MaxSum = ThisSum;
            start = starttemp;
            end = i;
        }
        else if (ThisSum < 0){
            ThisSum = 0;
            starttemp = i + 1;
        }
    }
    if (MaxSum < 0) MaxSum = 0;
    START = start;
    END = end;
    return MaxSum;
}

这里主要用的是动态规划的算法,我认为比较重要的一点就是一开始就对最大和MaxSum设置为-1,这样在测试数列全为负数时比较好处理。

目录
相关文章
|
3天前
|
人工智能 自然语言处理 Shell
深度评测 | 仅用3分钟,百炼调用满血版 Deepseek-r1 API,百万Token免费用,简直不要太爽。
仅用3分钟,百炼调用满血版Deepseek-r1 API,享受百万免费Token。阿里云提供零门槛、快速部署的解决方案,支持云控制台和Cloud Shell两种方式,操作简便。Deepseek-r1满血版在推理能力上表现出色,尤其擅长数学、代码和自然语言处理任务,使用过程中无卡顿,体验丝滑。结合Chatbox工具,用户可轻松掌控模型,提升工作效率。阿里云大模型服务平台百炼不仅速度快,还确保数据安全,值得信赖。
144205 24
深度评测 | 仅用3分钟,百炼调用满血版 Deepseek-r1 API,百万Token免费用,简直不要太爽。
|
5天前
|
人工智能 API 网络安全
用DeepSeek,就在阿里云!四种方式助您快速使用 DeepSeek-R1 满血版!更有内部实战指导!
DeepSeek自发布以来,凭借卓越的技术性能和开源策略迅速吸引了全球关注。DeepSeek-R1作为系列中的佼佼者,在多个基准测试中超越现有顶尖模型,展现了强大的推理能力。然而,由于其爆火及受到黑客攻击,官网使用受限,影响用户体验。为解决这一问题,阿里云提供了多种解决方案。
16629 37
|
13天前
|
机器学习/深度学习 人工智能 自然语言处理
PAI Model Gallery 支持云上一键部署 DeepSeek-V3、DeepSeek-R1 系列模型
DeepSeek 系列模型以其卓越性能在全球范围内备受瞩目,多次评测中表现优异,性能接近甚至超越国际顶尖闭源模型(如OpenAI的GPT-4、Claude-3.5-Sonnet等)。企业用户和开发者可使用 PAI 平台一键部署 DeepSeek 系列模型,实现 DeepSeek 系列模型与现有业务的高效融合。
|
5天前
|
并行计算 PyTorch 算法框架/工具
本地部署DeepSeek模型
要在本地部署DeepSeek模型,需准备Linux(推荐Ubuntu 20.04+)或兼容的Windows/macOS环境,配备NVIDIA GPU(建议RTX 3060+)。安装Python 3.8+、PyTorch/TensorFlow等依赖,并通过官方渠道下载模型文件。配置模型后,编写推理脚本进行测试,可选使用FastAPI服务化部署或Docker容器化。注意资源监控和许可协议。
1301 8
|
13天前
|
人工智能 搜索推荐 Docker
手把手教你使用 Ollama 和 LobeChat 快速本地部署 DeepSeek R1 模型,创建个性化 AI 助手
DeepSeek R1 + LobeChat + Ollama:快速本地部署模型,创建个性化 AI 助手
3411 117
手把手教你使用 Ollama 和 LobeChat 快速本地部署 DeepSeek R1 模型,创建个性化 AI 助手
|
8天前
|
人工智能 自然语言处理 API
DeepSeek全尺寸模型上线阿里云百炼!
阿里云百炼平台近日上线了DeepSeek-V3、DeepSeek-R1及其蒸馏版本等六款全尺寸AI模型,参数量达671B,提供高达100万免费tokens。这些模型在数学、代码、自然语言推理等任务上表现出色,支持灵活调用和经济高效的解决方案,助力开发者和企业加速创新与数字化转型。示例代码展示了如何通过API使用DeepSeek-R1模型进行推理,用户可轻松获取思考过程和最终答案。
|
5天前
|
人工智能 自然语言处理 程序员
如何在通义灵码里用上DeepSeek-V3 和 DeepSeek-R1 满血版671B模型?
除了 AI 程序员的重磅上线外,近期通义灵码能力再升级全新上线模型选择功能,目前已经支持 Qwen2.5、DeepSeek-V3 和 R1系列模型,用户可以在 VSCode 和 JetBrains 里搜索并下载最新通义灵码插件,在输入框里选择模型,即可轻松切换模型。
928 14
|
12天前
|
API 开发工具 Python
阿里云PAI部署DeepSeek及调用
本文介绍如何在阿里云PAI EAS上部署DeepSeek模型,涵盖7B模型的部署、SDK和API调用。7B模型只需一张A10显卡,部署时间约10分钟。文章详细展示了模型信息查看、在线调试及通过OpenAI SDK和Python Requests进行调用的步骤,并附有测试结果和参考文档链接。
1932 9
阿里云PAI部署DeepSeek及调用
|
9天前
|
人工智能 数据可视化 Linux
【保姆级教程】3步搞定DeepSeek本地部署
DeepSeek在2025年春节期间突然爆火出圈。在目前DeepSeek的网站中,极不稳定,总是服务器繁忙,这时候本地部署就可以有效规避问题。本文以最浅显易懂的方式带读者一起完成DeepSeek-r1大模型的本地部署。
|
12天前
|
缓存 自然语言处理 安全
快速调用 Deepseek API!【超详细教程】
Deepseek 强大的功能,在本教程中,将指导您如何获取 DeepSeek API 密钥,并演示如何使用该密钥调用 DeepSeek API 以进行调试。

热门文章

最新文章