MySQL 5.7启动失败

简介:
1.1.1 现象

下载MySQL 5.7的zip包解压缩以后,配置好data、tmp目录,启动数据库失败,查看错误日志内容如下:

mysqld: Table 'mysql.plugin' doesn't exist

2015-10-22T06:17:52.073875Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

1.1.2 原因

应该是没有默认数据库导致。

1.1.3 解决

先将my.default.ini改名为my.ini放到bin目录

命令行执行: mysqld --initialize --user=mysql --console

先执行以上命令, 生成库. 注意有个临时密码, 要记下来.

然后启动服务,用MySQL Workbench连接数据库,输入刚才的临时密码,Workbench会要求修改密码,此时将密码修改为自己的密码即可。






本文转自 tywali 51CTO博客,原文链接:http://blog.51cto.com/lancelot/1775966,如需转载请自行联系原作者
相关实践学习
每个IT人都想学的“Web应用上云经典架构”实战
本实验从Web应用上云这个最基本的、最普遍的需求出发,帮助IT从业者们通过“阿里云Web应用上云解决方案”,了解一个企业级Web应用上云的常见架构,了解如何构建一个高可用、可扩展的企业级应用架构。
MySQL数据库入门学习
本课程通过最流行的开源数据库MySQL带你了解数据库的世界。   相关的阿里云产品:云数据库RDS MySQL 版 阿里云关系型数据库RDS(Relational Database Service)是一种稳定可靠、可弹性伸缩的在线数据库服务,提供容灾、备份、恢复、迁移等方面的全套解决方案,彻底解决数据库运维的烦恼。 了解产品详情: https://www.aliyun.com/product/rds/mysql 
目录
相关文章
|
关系型数据库 MySQL Linux
【Linux】安装Mysql(附加service mysql启动失败 提示unit not found 解决办法)
【Linux】安装Mysql(附加service mysql启动失败 提示unit not found 解决办法)
1493 0
|
关系型数据库 MySQL 测试技术
mysql缺少binlog启动失败
因为磁盘满了,就直接把binlog都统统给删了(通常会留最后几个,因为直觉告诉我,都删了肯定有问题),今天没注意都给删了,然后起msyql时就起不来了。
730 0
mysql缺少binlog启动失败
|
关系型数据库 MySQL Linux
linux系统mysql服务启动失败
linux系统mysql服务启动失败
linux系统mysql服务启动失败
|
关系型数据库 MySQL Linux
MySQL 启动失败的常见原因---发表到爱可生开源社区
MySQL 启动失败的最常见的原因有两类,分别是无法访问系统资源和参数设置错误造成的,下面分别分析如下。
721 0
|
关系型数据库 MySQL PHP
MySQL - 如何查看 MySQL 服务启动失败具体问题
MySQL - 如何查看 MySQL 服务启动失败具体问题
517 0
MySQL - 如何查看 MySQL 服务启动失败具体问题
|
监控 关系型数据库 MySQL
阿里云CentOS 7.2 MySQL服务启动失败的解决思路
阿里云 CentOS 7.2 MySQL服务启动失败的解决思路 前言 : 昨天刚刚搭建好的MySQL让老大看了一下,经过测试已经完成任务。但是今天早晨来的时候发现服务器被关了,此时我的心情崩溃的,但是我非常冷静的解决了MySQL问题。
1691 0
|
关系型数据库 MySQL Linux
linux环境下 xampp mysql 启动失败问题排查 日志文件过大占用存储空间导致网站瘫痪
问题现象 网站莫名其妙的连接不上mysql了,导致网站瘫痪;没有改任何程序,怎么回事呢?马上用xshell 和xftp工具连接linux服务器来排查问题 启动xampp mysql /opt/lampp/lampp startmysql 启动xampp mysql ![/opt/lampp/bin/mysql.
3642 0

推荐镜像

更多