ACM- Jungle Roads(第九天-图论)

简介: Jungle Roads Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19852   Accepted: 9136 Description The H...
Jungle Roads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19852   Accepted: 9136

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Source

这道题目刚开始出现太多次状况,因为早上才迷迷糊糊地听了一点图论的东西,下午就碰到这道题。
题目的大意是在读入的地图里删掉那些昂贵又不是必要的路径(只要有一条路包含所有点就可以了)来减少开支,然后对每行数据输出最小的开支。
首先是一个读入的问题,来自C语言的同学表示不喜欢用cin所以用的是scanf读入,读入的时候要注意,以scanf(" %c %d",&c,&w[i]);不然因为读入格式错误真的是很讨厌,题主用的是Kruskal算法,主要就是一个并查集的应用吧。
下面附上代码:


#include<cstdio>
#include <iostream>
#include<algorithm>
using namespace std;
int u[80],v[80];
int w[80];
int p[80],r[80];
int cnt;
int n;
int cmp(const int i, const int j){
	return w[i] < w[j];
}
int find(int x){
	return p[x] == x ? x:p[x] = find(p[x]);
}
int Kruskal(){
	int ans = 0;
	for(int i = 1;i <= n;i++)
		p[i] = i;
	for(int i = 1;i < cnt;i++)
		r[i] = i;
	sort(r+1,r+cnt+1,cmp);
//	cout<<"cnt == "<<cnt<<endl;
	for(int i = 1;i <= cnt;i++){
		int o = r[i];
		int x = find(u[o]);
		int y = find(v[o]);
		if(x != y){
			ans += w[o];
			p[x] = y;
		}
	}
	return	ans;
}
int main(){
	while(scanf("%d",&n) && n){
		int muc;
		cnt =1;
		for(int i = 1;i < n;i++){
			char s,e;
			scanf(" %c %d",&s,&muc);
			for(int i = cnt;i < cnt+muc;i++){
				scanf(" %c %d",&e,&w[i]);
				u[i] = s - 'A' + 1;
				v[i] = e - 'A' + 1;
			}
			cnt += muc;
		}
		int answer = Kruskal();
		printf("%d\n",answer);
	}
	return	0;
}


相关文章
|
程序员
ACM刷题之路(一)第K个排列问题 Ignatius and the Princess II
ACM刷题之路(一)第K个排列问题 Ignatius and the Princess II
|
BI
2020ICPC济南站 A . Matrix Equation (高斯消元)
2020ICPC济南站 A . Matrix Equation (高斯消元)
100 0
2020ICPC济南站 A . Matrix Equation (高斯消元)
|
机器学习/深度学习 BI
2020-2021 ACM-ICPC, Asia Seoul Regional Contest L. Two Buildings (决策单调性 分治)
2020-2021 ACM-ICPC, Asia Seoul Regional Contest L. Two Buildings (决策单调性 分治)
128 0
2020-2021 ACM-ICPC, Asia Seoul Regional Contest L. Two Buildings (决策单调性 分治)
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
98 0
2021杭电多校第三场-Road Discount-wqs二分+最小生成树
get函数是求出将黑色的边权加上一个值x之后的一个花费,我们会这个函数处理出x=-1000->1000的所有情况,然后将信息储存在save中,然后在询问的时候,直接遍历save集合,遇见满足情况的便直接输出,否则输出-1,虽然没有-1的情况/doge
136 0
2021杭电多校第三场-Road Discount-wqs二分+最小生成树
Mad Scientist (纯模拟题)
Mad Scientist 题目描述 Farmer John’s cousin Ben happens to be a mad scientist. Normally, this creates a good bit of friction at family gatherings, but it can occasionally be helpful, especially when Farmer John finds himself facing unique and unusual problems with his cows.
136 0
|
Java
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem F. Four-tuples
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem F. Four-tuples
140 0
|
人工智能 Java
HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem C. Sequence
HDU - 2018杭电ACM集训队单人排位赛 - 4 - Problem C. Sequence
109 0
|
人工智能 Java
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem E. Sequence
HDU - 2018杭电ACM集训队单人排位赛 - 3 - Problem E. Sequence
146 0