畅通工程,How Many Tables ACM第九天-图论

简介: 下面两题的方法是一样的都是并查集的应用; 并查集的重点就是找到祖先节点的过程。 重点在这里:int find(int x){ return p[x] == x ? x : p[x] = find( p[x]); } 不断地递归,递归到找到自己是自己的祖先为止。
下面两题的方法是一样的都是并查集的应用;
并查集的重点就是找到祖先节点的过程。
重点在这里:int find(int x){ return p[x] == x ? x : p[x] = find( p[x]); }
不断地递归,递归到找到自己是自己的祖先为止。并且把它取接到那个祖先节点上;这样可以节省空间和时间。

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15414    Accepted Submission(s): 7560


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
 
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
 
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy
 


#include <cstdio>
#define maxn 1005
using namespace std;
int p[maxn];
int a[maxn];
int b[maxn];
int find(int x){
	return	p[x] == x? x : p[x] = find(p[x]);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
		scanf("%d %d",&n,&m);
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&a[i],&b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= n;i++){
			p[i] = i;
		}
		for(int i = 0;i <= m;i++){
			int x = find(a[i]);
			int y = find(b[i]);
			if(x != y){
				ans++;
				p[x] = y;
			}
		}
		int answer = n - ans;
		printf("%d\n",answer);
	}
	return	0;
}

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32971    Accepted Submission(s): 17391


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 

Sample Input
 
     
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
 
     
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
 

Source
 

Recommend
JGShining
 

 
 
#include <cstdio>
#include <cstring>

using namespace std;
#define maxn 1005
int p[maxn];
int a[maxn];
int b[maxn];
int find(int x){
	return	p[x] == x? x : p[x] = find(p[x]);
}
int main(){
	int n,m;
	while(scanf("%d %d",&n,&m) && n){
		memset(p,0,sizeof(p));
		for(int i = 1;i <= m;i++){
			scanf("%d %d",&a[i],&b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= n;i++){
			p[i] = i;
		}
		for(int i = 0;i <= m;i++){
			int x = find(a[i]);
			int y = find(b[i]);
			if(x != y){
				ans++;
				p[x] = y;
			}
		}
		int answer = n - 1 - ans;
		printf("%d\n",answer);
	}
	return	0;
}


相关文章
ACM- Jungle Roads(第九天-图论)
Jungle Roads Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19852   Accepted: 9136 Description The H...
947 0
|
存储 缓存 算法
[SIGMOD 22 学习]《Adaptive Hybrid Indexes》解读
本文是学习总结,有错误处欢迎交流。
436 0
|
6月前
|
机器学习/深度学习 算法 数据挖掘
【博士每天一篇文-算法】Graph Structure of Neural Networks
本文介绍了尤家轩在2020年发表于国际机器学习会议上的研究,该研究探讨了神经网络的图结构与预测性能之间的关系,并提出了一种新的关系图表示方法,揭示了神经网络性能与图聚类系数和平均路径长度的函数关系,同时发现最优神经网络图结构与生物神经网络相似。
33 2
【博士每天一篇文-算法】Graph Structure of Neural Networks
|
6月前
|
机器学习/深度学习 存储 算法
【博士每天一篇文献-算法】Machine Unlearning via Representation Forgetting With Parameter Self-Sharing
这篇论文提出了一种名为"表示遗忘反学习与参数自共享"(RFU-SS)的新方法,通过双目标优化问题的形式,在减少模型准确性降低的同时,有效地从训练好的机器学习模型中移除特定样本的影响。
110 0
|
6月前
|
数据可视化 算法 Go
【博士每天一篇文献-实验】Exploring the Morphospace of Communication Efficiency in Complex Networks
这篇论文探讨了复杂网络中不同拓扑结构下的通信效率,并使用"效率形态空间"来分析网络拓扑与效率度量之间的关系,得出结论表明通信效率与网络结构紧密相关。
56 3
|
人工智能
POJ1007-DNA Sorting-ACM
DNA Sorting Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 83442   Accepted: 33584 Description One measure of ``unsort...
806 0
|
6月前
|
机器学习/深度学习 算法 网络性能优化
【博士每天一篇文献-算法】A brain-inspired algorithm that mitigates catastrophic forgetting of
本文提出了一种受大脑启发的神经调节辅助信用分配(NACA)算法,该算法通过模拟大脑中的神经调节机制,有效减轻了人工神经网络(ANNs)和脉冲神经网络(SNNs)在学习过程中的灾难性遗忘问题,并具有较低的计算成本。
75 1
|
6月前
|
机器学习/深度学习 数据挖掘
【博士每天一篇文献-综述】Communication dynamics in complex brain networks
本文综述了复杂脑网络中的通信动态,提出了一个将通信动态视为结构连接和功能连接之间必要联系的概念框架,探讨了结构网络的局部和全局拓扑属性如何支持网络通信模式,以及网络拓扑与动态模型之间的相互作用如何提供对大脑信息转换和处理机制的额外洞察。
63 2
【博士每天一篇文献-综述】Communication dynamics in complex brain networks

热门文章

最新文章