Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10
6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
题目大意:
就是求一个F(n)的中元素的个数。
解题思路:
首先我们分析一下题目,我们一看就是关于欧拉函数的题,就是求<=b中与b互素的个数,但是我们别忘记还得加上phi(<n)的值,所以这个问题就是求欧拉函数的和的问题,然后我们如果用正常的做法也就是暴力做的话 会超时的(我试过了/笑cry),所以我们要找到更快速的方法 ——筛法,其实这个筛法就是跟素数筛差不多的,也算是又学了一个知识点
void Init() { memset(phi, 0, sizeof(phi)) ; for(int i=2; i<MAXN; i++) { if(!phi[i]) { for(int j=i; j<MAXN;j+=i ) { if(!phi[j]) phi[j] = j ; phi[j] = phi[j]/i*(i-1) ; } } } }
Code:
#include <iostream> #include <algorithm> #include <cstring> using namespace std; typedef long long LL; const int MAXN = 1e6+5; int phi[MAXN]; void Init() { memset(phi, 0, sizeof(phi)) ; for(int i=2; i<MAXN; i++) { if(!phi[i]) { for(int j=i; j<MAXN;j+=i ) { if(!phi[j]) phi[j] = j ; phi[j] = phi[j]/i*(i-1) ; } } } } int main() { Init(); int m; while(cin>>m,m) { LL sum = 0; for(int i=2; i<=m; i++) sum += phi[i]; cout<<sum<<endl; } return 0; }