POJ-2752-Seek the Name, Seek the Fame

简介: POJ-2752-Seek the Name, Seek the Fame




Seek the Name, Seek the Fame

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 43   Accepted Submission(s) : 24

Problem Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:


Step1. Connect the father's name and the mother's name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).


Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

 


Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.


Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

 


Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

 


Sample Input

      ababcababababcabab aaaaa      

 


Sample Output

      2 4 9 18 1 2 3 4 5      

 


Source

PKU



题目分析:

题目意思是让你输出所有首尾相同子串的长度  例如abab cabab ababcabab       有首ab尾ab   首 abab尾abab    首ababcabab尾 ababcabab        ababcababababcabab

  i     0      1       2        3       4      5     6

     a    b     a     b    a    b

  j     -1     0        0       1       2      3     4

p[6]=4,p[5]=3,p[4]=2,p[3]=1,p[2]=0,p[1]=0,p[0]=-1.

到6时匹配失败跳转到p[6]=4位置说明4 符合要求   p[4]=2 说明2符合 所以  有  2  4  6

#include<cstdio>
#include<cstring>
const int M=400000+10;
int len;
char str[M];
int p[M],a[M];
void getp()
{
  int i=0,j=-1;
  p[i]=j;
  while(i<len)
  {
    if(j==-1||str[i]==str[j])
    {
      i++;j++;
      p[i]=j;
    }
    else j=p[j];
  }
}
int main()
{
  while(~scanf("%s",str))
  {
    len=strlen(str);
    getp();
    int j=0;
    for(int i=len;p[i]!=-1;i=p[i])// 此处就是统计相同首尾的长度
        a[j++]=i;
    for(int i=j-1;i>=0;i--)
        printf("%d ",a[i]);
        printf("\n");
  }
  return 0;
}



目录
相关文章
|
5月前
|
C语言
C语言进阶——sprintf与sscanf、文件的随机读写(fseek、ftell、rewind)
C语言进阶——sprintf与sscanf、文件的随机读写(fseek、ftell、rewind)
43 0
|
6月前
|
C语言
文件操作(二、scanf/fscanf/sscanf​与printf/fprintf/sprintf​、fseek与ftell与rewind、feof)
文件操作(二、scanf/fscanf/sscanf​与printf/fprintf/sprintf​、fseek与ftell与rewind、feof)
|
存储
华为机试HJ64:MP3光标位置
华为机试HJ64:MP3光标位置
文件操作以及相关的函数fwrite,fread,fseek,ftell,rwind,feof
🐰文件操作 🌸 fwrite 🌸fread 🌸fseek 🌸fteel 🌸rwind 🌸文本文件和二进制文件 🌸文件结束的判定 🌸文件缓冲区 🌸 实现拷贝一个文件
|
人工智能
HDU6656——Kejin Player(期望DP+前缀和)
HDU6656——Kejin Player(期望DP+前缀和)
90 0
HDU6656——Kejin Player(期望DP+前缀和)
|
开发者 Python
seek( ) 和 tell( )|学习笔记
快速学习 seek( ) 和 tell( )
138 0
|
存储 算法 测试技术
Seek the Name, Seek the Fame(求名求名) (kmp) POJ-2752
题目:Seek the Name, Seek the Fame(求名求名)
|
移动开发
seek()对中文偏移测试
当前目录下创建“中文测试.txt”文件,写入: 我是大好人aaa我是大坏人bbb f = open('中文测试.txt', 'r+', encoding='utf-8') # f.write('我是大好人aaa\n') # f.
976 0