ZigZagging on a Tree二叉树蛇形层次遍历(Java语言)

简介: ZigZagging on a Tree二叉树蛇形层次遍历(Java语言)

题目描述:

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

4726b256e87946f188365e2f21fc5300.png


Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.


Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.


Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

解题思路:

根据中序和后序创建二叉树,最后蛇形层次遍历(遍历一层就开始反转一次,Java中使用了LinkedList进行存储处理)

代码中有根据中序和后序创建二叉树的模板,有层次遍历的模板;

先序和中序创建二叉树的模板参考先序和中序创建二叉树

代码:

package text_9_25;

import java.util.ArrayList;
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class ZigZaggingOnATree {
  public static void main(String[] args) {
    // TODO Auto-generated method stub
    Scanner scanner = new Scanner(System.in);
    int n = scanner.nextInt();
    int in[] = new int[n];
    int post[] = new int[n];
    for(int i=0;i<n;i++)
      in[i] = scanner.nextInt();
    for(int i=0;i<n;i++)
      post[i] = scanner.nextInt();
    //创建二叉树
    Node root = BuildTree(in, 0, n-1, post, 0, n-1);
    
    //蛇形层次遍历
    PrintLevelOrder(root);

    
  }
  
  public static Node BuildTree(int in[],int ibegin,int iend,int post[],int pbegin,int pend) {
    if(ibegin>iend||pbegin>pend) return null;
    Node root = new Node(post[pend]);
    for(int i=ibegin;i<=iend;i++) {
      if(post[pend]==in[i]) {
        root.left = BuildTree(in, ibegin, i-1, post, pbegin, pbegin-ibegin+i-1);
        root.right = BuildTree(in, i+1, iend, post, pbegin-ibegin+i, pend-1);
      }
    }
    return root;
  }
  public static void PrintLevelOrder(Node root) {
    boolean reversed = false;//反转标志
    Queue<Node> queue = new LinkedList<>();
    queue.add(root);
    int flag=1;//用于输出格式控制
    while(!queue.isEmpty()) {
      int size = queue.size();//当前层的节点数
      LinkedList<Integer> link = new LinkedList<>();//保存当前层结果,LinkedList可以前后插入
      for(int i=0;i<size;i++) {  //对应每一层
        Node temp = queue.poll();
        if(reversed) link.add(temp.data);
        else link.addFirst(temp.data);
        
        if(temp.left!=null) queue.add(temp.left);
        if(temp.right!=null) queue.add(temp.right);
      }
//      System.out.println(size);
      for(int j=0;j<link.size();j++) {
        if(flag==1) {
          System.out.print(link.get(j));
          flag=0;
        }
        else System.out.print(" "+link.get(j));
      }
      reversed =!reversed;  //每次反转
    }
  }

}
class Node{   //树节点类
  public int data;
  public Node left;
  public Node right;
  public Node(int data){
    this.data = data;
    left = right = null;
  }
}

相关文章
|
2月前
|
监控 Java API
如何使用Java语言快速开发一套智慧工地系统
使用Java开发智慧工地系统,采用Spring Cloud微服务架构和前后端分离设计,结合MySQL、MongoDB数据库及RESTful API,集成人脸识别、视频监控、设备与环境监测等功能模块,运用Spark/Flink处理大数据,ECharts/AntV G2实现数据可视化,确保系统安全与性能,采用敏捷开发模式,提供详尽文档与用户培训,支持云部署与容器化管理,快速构建高效、灵活的智慧工地解决方案。
|
7天前
|
Oracle Java 关系型数据库
Java基础(一):语言概述
Java基础(一):语言概述
Java基础(一):语言概述
|
16天前
|
存储 监控 算法
探秘局域网桌面监控:深入剖析 Java 语言核心算法
在数字化办公时代,局域网桌面监控如同企业的“智慧鹰眼”,确保工作效率与数据安全。本文以Java为载体,揭示哈希表在监控中的关键应用。通过高效的数据结构和算法,哈希表能快速索引设备连接信息,大幅提升监控的时效性和响应速度。代码示例展示了如何用Java实现设备网络连接监控,结合未来技术如AI、大数据,展望更智能的监控体系,助力企业在数字化浪潮中稳健前行。
|
2月前
|
SQL 安全 Java
安全问题已经成为软件开发中不可忽视的重要议题。对于使用Java语言开发的应用程序来说,安全性更是至关重要
在当今网络环境下,Java应用的安全性至关重要。本文深入探讨了Java安全编程的最佳实践,包括代码审查、输入验证、输出编码、访问控制和加密技术等,帮助开发者构建安全可靠的应用。通过掌握相关技术和工具,开发者可以有效防范安全威胁,确保应用的安全性。
62 4
|
3月前
|
Java 程序员 编译器
在Java编程中,保留字(如class、int、for等)是具有特定语法意义的预定义词汇,被语言本身占用,不能用作变量名、方法名或类名。
在Java编程中,保留字(如class、int、for等)是具有特定语法意义的预定义词汇,被语言本身占用,不能用作变量名、方法名或类名。本文通过示例详细解析了保留字的定义、作用及与自定义标识符的区别,帮助开发者避免因误用保留字而导致的编译错误,确保代码的正确性和可读性。
76 3
|
3月前
|
移动开发 Java 大数据
深入探索Java语言的核心优势与现代应用实践
【10月更文挑战第10天】深入探索Java语言的核心优势与现代应用实践
126 4
|
2月前
|
算法 Java
JAVA 二叉树面试题
JAVA 二叉树面试题
29 0
|
存储 Java 编译器
Java语言------图书馆管理系统(入门简略版)
Java语言------图书馆管理系统(入门简略版)
136 0
Java语言------图书馆管理系统(入门简略版)
|
小程序 安全 前端开发
【Java编程进阶】Java语言基础入门篇
整个Java全栈编程知识体系十分庞大,包括JavaSE知识,Web前端,Web后端,数据库相关的知识等,初学者应该系统踏实的学习,一步一个脚印。Java语言是一种完全面向对象的跨平台语言。有很多突出的优点,例如简单易学,面向对象,分布式,安全可靠,解释型语言,跨平台运行,可移植高性能多线程,可实现网络编程等。
192 0
【Java编程进阶】Java语言基础入门篇
|
Java
Java学习路线-53:EL(表达式语言)入门及 EL 函数库
Java学习路线-53:EL(表达式语言)入门及 EL 函数库
126 0