A+B for Input-Output Practice

简介: A+B for Input-Output Practice

A+B for Input-Output Practice

你的任务是求许多数的和。

Input

第一行需要输入一个整数N,接下来会有N行。 每一行开始输入一个整数M,然后会有M个数在同一行。

 

Output

对于每组输入,要求在一行输出它们的和。并且你要保证每组输出之间有一空行。

 

Sample Input

3

4 1 2 3 4

5 1 2 3 4 5

3 1 2 3

Sample Output

10


15


6

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int n, i, j, x, y, sum;
    scanf("%d", &n);
    for(i = 1; i <= n; i++)
    {
        scanf("%d", &x);
        sum = 0;
        for(j = 1; j <= x; j++)
        {
            scanf("%d", &y);
            sum = sum + y;
        }
        printf("%d\n", sum);
        if(i != n)
        {
            printf("\n");
        }
    }
    return 0;
}


相关文章
(standard input): No keywords in input file
(standard input): No keywords in input file
124 0
HDOJ 1091 A+B for Input-Output Practice (III)
HDOJ 1091 A+B for Input-Output Practice (III)
100 0
HDOJ 1090 A+B for Input-Output Practice (II)
HDOJ 1090 A+B for Input-Output Practice (II)
107 0
HDOJ 1089 A+B for Input-Output Practice (I)
HDOJ 1089 A+B for Input-Output Practice (I)
116 0
HDOJ 1093 A+B for Input-Output Practice (V)
HDOJ 1093 A+B for Input-Output Practice (V)
99 0
|
关系型数据库 MySQL 数据库管理