HDU 1506 Largest Rectangle in a Histogram(单调栈)

简介: HDU 1506 Largest Rectangle in a Histogram(单调栈)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
在这里插入图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000

自己一开始用一次单调栈来求,先单调增,不行;又单调减,也不行。。。果断放弃,看题解,代码抄下来有一点明白了。大体思路是这样的,先从左到右遍历一次,求出每个点向左扩展的最大距离,比如说l[5]=2是指5号点向左一直到2号点都比5号高。然后在从右向左遍历一次,求出每个点向右扩展的最大距离。这样以每个点为最低点向左向右的扩展都能求出来,在计算一下求最大值就好了。

#include <iostream>
#include <cstdio>
#include <stack>
#include <algorithm>
using namespace std;

int a[100005], l[100005], r[100005];
int main()
{
   
   
    int n;
    stack<int> s;
    while (scanf("%d", &n)!=EOF && n){
   
   
        for (int i=1; i<=n; i++)
            scanf("%d", &a[i]);

        while (!s.empty())    s.pop();
        for (int i=1; i<=n; i++){
   
   
            while (s.size() && a[s.top()]>=a[i])
                s.pop();
            if (s.empty())
                l[i]=0;
            else
                l[i]=s.top();
            s.push(i);
        }

        while (!s.empty())    s.pop();
        for (int i=n; i>=1; i--){
   
   
            while (s.size() && a[s.top()]>=a[i])
                s.pop();
            if (s.empty())
                r[i]=n+1;
            else
                r[i]=s.top();
            s.push(i);
        }

        long long ans=0;
        for (int i=1; i<=n; i++)
            ans=max(ans, (long long)a[i]*(r[i]-l[i]-1));
        printf("%lld\n", ans);
    }
    return 0;
}
相关文章
|
6天前
|
算法 C语言 C++
【practise】栈的压入和弹出序列
【practise】栈的压入和弹出序列
|
4天前
栈的几个经典应用,真的绝了
文章总结了栈的几个经典应用场景,包括使用两个栈来实现队列的功能以及利用栈进行对称匹配,并通过LeetCode上的题目示例展示了栈在实际问题中的应用。
栈的几个经典应用,真的绝了
|
1天前
|
负载均衡 网络协议 安全
DKDP用户态协议栈-kni
DKDP用户态协议栈-kni
|
1天前
|
负载均衡 网络协议 安全
DPDK用户态协议栈-KNI
DPDK用户态协议栈-KNI
|
1天前
|
测试技术
【初阶数据结构篇】栈的实现(附源码)
在每一个方法的第一排都使用assert宏来判断ps是否为空(避免使用时传入空指针,后续解引用都会报错)。
|
4天前
|
存储 网络协议 Linux
用户态协议栈06-TCP三次握手
用户态协议栈06-TCP三次握手
|
4天前
|
存储
全局变量和局部变量在堆和栈的区别
全局变量和局部变量在堆和栈的区别
13 0
|
5天前
|
存储 人工智能 运维
高质量存储力发展问题之浪潮信息发布的大模型智算软件栈的定义如何解决
高质量存储力发展问题之浪潮信息发布的大模型智算软件栈的定义如何解决
9 0
|
6天前
|
设计模式 算法 C语言
【CPP】栈、双端队列、队列、优先级队列与反向迭代器
【CPP】栈、双端队列、队列、优先级队列与反向迭代器
|
6天前
|
存储 算法 C++
【CPP】栈简介及简化模拟实现
【CPP】栈简介及简化模拟实现