虚拟网络的搭建

简介: 虚拟网络的搭建

题目

一.首先给各个网段划分IP

二.在ISP上给每个接口都配上IP

[ISP]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 6
The number of interface that is DOWN in Physical is 3
The number of interface that is UP in Protocol is 6
The number of interface that is DOWN in Protocol is 3
Interface                         IP Address/Mask      Physical   Protocol  
GigabitEthernet0/0/0              3.3.3.2/24           up         up        
GigabitEthernet0/0/1              unassigned           down       down      
GigabitEthernet0/0/2              unassigned           down       down      
LoopBack0                         5.5.5.1/24           up         up(s)     
NULL0                             unassigned           up         up(s)     
Serial3/0/0                       2.2.2.2/24           up         up        
Serial3/0/1                       unassigned           down       down      
Serial4/0/0                       1.1.1.2/24           up         up        
Serial4/0/1                       4.4.4.2/24           up         up        

1.R1和R5之间使用ppp的pap认证,R5为主认证方

[R1]aaa
[R1-aaa]local-user admin password cipher 123456 
[R1-aaa]local-user admin service-type ppp 
[R1-aaa]q
[R1]interface Serial 4/0/0  
[R1-Serial4/0/0]ppp authentication-mode pap
[ISP]int s4/0/0
[ISP-Serial4/0/0]ppp pap local-user admin password cipher 123456
###PPP会话是一次性会话,会话一旦建立,再配置认证将不生效,再下次会话建立时
才生效,所以下方重启接口了
[ISP-Serial4/0/0]shutdown 
[ISP-Serial4/0/0]undo shutdown 
[ISP-Serial4/0/0]display this 
[V200R003C00]
#
interface Serial4/0/0
 link-protocol ppp
 ppp pap local-user admin password cipher %$%$::i-%`5&4%z^qW-Se5^4,+\*%$%$
 ip address 1.1.1.2 255.255.255.0 
#
return

2.R4和R5之间使用ppp的chap认证,R5为主认证方

[R4-Serial4/0/0]ppp chap user admin
[R4-Serial4/0/0]ppp chap password cipher 123456
[ISP]int s4/0/1
[ISP-Serial4/0/1]ppp authentication-mode chap
[ISP-Serial4/0/1]shutdown 
[ISP-Serial4/0/1]undo shutdown 
[R4-Serial4/0/0]display this
[V200R003C00]
#
interface Serial4/0/0
 link-protocol ppp
 ppp chap user admin
 ppp chap password cipher %$%$Pu^NH.P<BV]0NmQLHzKS,+e~%$%$
 ip address 4.4.4.1 255.255.255.0 
#
return

3.R2和R5使用HDLC封装

[R2]int s4/0/0
[R2-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
Sep 17 2022 19:10:50-08:00 R2 %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed 
the configuration that will change the encapsulation protocol of the link and th
en selected Y. 
[ISP-Serial3/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
Sep 17 2022 19:12:22-08:00 ISP %%01IFNET/4/CHANGE_ENCAP(l)[8]:The user performed
 the configuration that will change the encapsulation protocol of the link and t
hen selected Y. 
[ISP-Serial3/0/0]display this
[V200R003C00]
#
interface Serial3/0/0
 link-protocol hdlc
 ip address 2.2.2.2 255.255.255.0 
#
return

三.R1、R3之间为点到点的GRE

[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip add 192.168.5.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre
[R1-Tunnel0/0/0]source 1.1.1.1
[R1-Tunnel0/0/0]destination 3.3.3.1
Sep 17 2022 19:21:40-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip add 192.168.5.2 24
[R3-Tunnel0/0/0]tunnel-protocol gre
[R3-Tunnel0/0/0]source 3.3.3.1
[R3-Tunnel0/0/0]destination 1.1.1.1

R1/R2/R4构建一个MGRE环境,R1为中心站点

[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]ip add 192.168.6.1 24 
[R1-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/1]source 1.1.1.1
Sep 17 2022 19:39:34-08:00 R1 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP 
on the interface Tunnel0/0/1 has entered the UP state. 
[R1-Tunnel0/0/1]nhrp network-id 100
[R4]int Tunnel 0/0/1
[R4-Tunnel0/0/1]ip add 192.168.6.3 24
[R4-Tunnel0/0/1]tunnel-protocol gre p2mp  
[R4-Tunnel0/0/1]source Serial 4/0/0
[R4-Tunnel0/0/1]nhrp network-id 100
[R4-Tunnel0/0/1]nhrp entry 192.168.6.1 1.1.1.1 register 
[R2]int Tunnel 0/0/1
[R2-Tunnel0/0/1]ip add 192.168.6.2 24
[R2-Tunnel0/0/1]tunnel-protocol gre p2mp  
[R2-Tunnel0/0/1]source Serial 4/0/0
[R2-Tunnel0/0/1]nhrp network-id 100
[R2-Tunnel0/0/1]nhrp entry 192.168.6.1 1.1.1.1 register 

四.实现整个私有网络基于RIP全网可达

五.使用PC访问R5环回可通

目录
相关文章
|
1天前
|
人工智能 安全 网络安全
揭秘网络危机模拟:现场vs.虚拟,未来创新何在?
揭秘网络危机模拟:现场vs.虚拟,未来创新何在?
|
4月前
|
存储 安全 网络安全
云计算与网络安全的博弈:保护数据在虚拟世界中的安全移动应用开发之旅:从新手到专家
【8月更文挑战第27天】随着云计算技术的飞速发展,企业和个人用户越来越多地将数据和服务迁移到云端。然而,这一转变同时带来了新的安全挑战。本文旨在探讨云计算环境下的网络安全问题,并分析如何通过技术和策略保障信息安全。我们将从云服务的基础知识出发,逐步深入到网络安全和信息安全的高级概念,最后讨论如何实施有效的安全措施来抵御网络威胁。文章不仅涵盖了理论框架,还提供了实际案例分析,旨在为读者提供一套全面的云计算安全指南。
|
4月前
|
JavaScript 网络协议 API
【Azure API 管理】Azure APIM服务集成在内部虚拟网络后,在内部环境中打开APIM门户使用APIs中的TEST功能失败
【Azure API 管理】Azure APIM服务集成在内部虚拟网络后,在内部环境中打开APIM门户使用APIs中的TEST功能失败
|
5月前
|
安全 网络安全 网络虚拟化
什么是VPN虚拟专业网络技术?
虚拟专用网络(VPN)技术利用互联网服务提供商(ISP)和网络服务提供商(NSP)的网络基础设备,在公用网络中建立专用的数据通信通道。VPN的主要优点包括节约成本和提供安全保障。
155 6
|
4月前
【Azure App Service】列举为App Service集成虚拟网络(VNET)操作时所需要的最小权限
【Azure App Service】列举为App Service集成虚拟网络(VNET)操作时所需要的最小权限
|
4月前
|
缓存 负载均衡 NoSQL
【Azure Redis】Azure Redis添加了内部虚拟网络后,其他区域的主机通过虚拟网络对等互连访问失败
【Azure Redis】Azure Redis添加了内部虚拟网络后,其他区域的主机通过虚拟网络对等互连访问失败
|
4月前
|
安全 网络安全
【Azure 环境】当本地网络通过ER专线与Azure云上多个虚拟网络打通,如何通过特定的网络策略来限制本地部分网段访问云上虚拟机22端口?
【Azure 环境】当本地网络通过ER专线与Azure云上多个虚拟网络打通,如何通过特定的网络策略来限制本地部分网段访问云上虚拟机22端口?
|
4月前
|
网络协议 安全
【Azure 应用服务】Azure Function集成虚拟网络,设置被同在虚拟网络中的Storage Account触发,遇见Function无法触发的问题
【Azure 应用服务】Azure Function集成虚拟网络,设置被同在虚拟网络中的Storage Account触发,遇见Function无法触发的问题
|
4月前
|
SQL 网络协议 安全
【Azure API 管理】APIM集成内网虚拟网络后,启用自定义路由管理外出流量经过防火墙(Firewall),遇见APIs加载不出来问题
【Azure API 管理】APIM集成内网虚拟网络后,启用自定义路由管理外出流量经过防火墙(Firewall),遇见APIs加载不出来问题
|
4月前
|
存储 缓存 NoSQL
【Azure Redis 缓存】Azure Cache for Redis 专用终结点, 虚拟网络, 公网访问链路
【Azure Redis 缓存】Azure Cache for Redis 专用终结点, 虚拟网络, 公网访问链路

热门文章

最新文章