6-4 学生成绩链表处理

简介: 本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。

6-4 学生成绩链表处理 (20分)


本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。


函数接口定义:


struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );


函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:


struct stud_node {
    int              num;      /*学号*/
    char             name[20]; /*姓名*/
    int              score;    /*成绩*/
    struct stud_node *next;    /*指向下个结点的指针*/
};


输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。


函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。


裁判测试程序样例:


#include <stdio.h>
#include <stdlib.h>
struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
int main()
{
    int min_score;
    struct stud_node *p, *head = NULL;
    head = createlist();
    scanf("%d", &min_score);
    head = deletelist(head, min_score);
    for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);
    return 0;
}
/* 你的代码将被嵌在这里 */


输入样例:


1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80


输出样例:


2 wang 80
4 zhao 85


题解


         /* 你的代码将被嵌在这里 */
struct stud_node *createlist()
{
  struct stud_node *pt;
  pt = (struct stud_node *)malloc(sizeof(struct stud_node));
  struct stud_node *head,*tail;
  head = tail = NULL;
  scanf("%d", &pt->num);
  while (pt->num != 0)
  {
    scanf("%s %d", pt->name, &pt->score);
    if (head == NULL)
      head = pt;
    else
      tail->next = pt;
    tail = pt;
    pt = (struct stud_node *)malloc(sizeof(struct stud_node));
    scanf("%d", &pt->num);
  }
  return head;
}
struct stud_node *deletelist(struct stud_node *head, int min_score)
{
  struct stud_node*p1, *p2;
//  // 头结点为空直接返回
//  if (head==NULL)
//  {
//    return NULL;
//  }
  // 先检查头结点是否小于
  while (head!=NULL&&head->score<min_score)
  {
    p1 = head;
    head = head->next;
    free(p1);
  }
      // 头结点为空直接返回
  if (head==NULL)
  {
    return NULL;
  }
  p1 = head;
  p2 = p1->next;
  // 头结点没问题了  看头结点以后
  // 后面要是没有直接跳过循环return   head就行
  while (p2!=NULL)
  {
    if (p2->score<min_score)
    {
      p1->next = p2->next;
      free(p2);
    }
    else
    {
      p1 = p2;
    }
    // 让p2等于下一个继续检验
    p2 = p1->next;
  }
  return head;
}
目录
打赏
0
0
0
0
40
分享
相关文章
|
3月前
|
链表题目练习及讲解(下)
链表题目练习及讲解(下)
43 9
|
3月前
链表题目练习及讲解(上)
链表题目练习及讲解(上)
38 1
|
3月前
|
C++
【九度 02】N个学生数据成绩排序
【九度 02】N个学生数据成绩排序
32 0
|
6月前
7-1 学生成绩排序
7-1 学生成绩排序
88 0
|
8月前
计蒜客_成绩排序
计蒜客_成绩排序
六六力扣刷题链表之 删除排序链表中的重复元素 II
六六力扣刷题链表之 删除排序链表中的重复元素 II
61 0