Knight Moves(POJ2243)

简介: Knight Moves(POJ2243)

题目:

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the

shortest closed tour of knight moves that visits each square of a given set of n squares on a

chessboard exactly once. He thinks that the most difficult part of the problem is determining the

smallest number of knight moves between two given squares and that, once you have accomplished

this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the “difficult”

part.

Your job is to write a program that takes two squares a and b as input and then determines the

number of knight moves on a shortest route from a to b.


Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying “To get from xx to yy takes n knight moves.”.

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

思路:这个题就是搜索,知道马走的是日,所以可以枚举八个方向的坐标去一步一步的走,直到找到另一个点。我把输入的a-h转换为1-8,这样就可以建立一个8*8的矩阵。

程序代码:

#include<stdio.h>
#include<string.h>
struct node
{
  int x;//横坐标
  int y;//纵坐标
  int s;  //步数
}que[2050];
int main()
{
  int a[301][301]={0},book[200][200]={0},b[10];
  int next[8][2]={{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1}};
  int head,tail;
  char n1,m1;
  int i,j,k,m,n,p,q,stx,sty,tx,ty,flag;
  for(i=1;i<=8;i++)
    b[i+'a'-1]=i;
  while(scanf("%c%d %c%d",&n1,&n,&m1,&m)!=EOF)
  {
    getchar();
    stx=n;
    sty=n1-'a'+1;
    p=m;
    q=m1-'a'+1;
    head=tail=1;
    que[tail].x=stx;
    que[tail].y=sty;
    que[tail].s=0;
    tail++;
    book[stx][sty]=1; 
    flag=0;
    while(head<tail)
    {
      if(stx==p&&sty==q)
        break;
      for(k=0;k<8;k++)
      {
        tx=que[head].x+next[k][0];
        ty=que[head].y+next[k][1];
        if(tx<1||tx>8||ty<1||ty>8)
          continue;
        if(book[tx][ty]==0)
        {
          book[tx][ty]=1;
          que[tail].x=tx;
          que[tail].y=ty;
          que[tail].s=que[head].s+1;
          tail++;
        }
        if(tx==p&&ty==q)
        {
          flag=1;
          break;
        }
      }
      if(flag==1)
        break;
      head++;
    }
    printf("To get from %c%d to %c%d takes %d knight moves.\n",n1,n,m1,m,que[tail-1].s);
    for(i=0;i<200;i++)
      for(j=0;j<200;j++)
        book[i][j]=0;
  } 
  return 0;
}


相关文章
|
机器学习/深度学习
1257:Knight Moves 2021-01-09
1257:Knight Moves 2021-01-09
LeetCode 70. Climbing Stairs
你正在爬楼梯。 它需要n步才能达到顶峰。 每次你可以爬1或2步。 您可以通过多少不同的方式登顶? 注意:给定n将是一个正整数。
65 0
LeetCode 70. Climbing Stairs
UVA699 下落的树叶 The Falling Leaves
UVA699 下落的树叶 The Falling Leaves
UVA699 下落的树叶 The Falling Leaves
POJ-2488,A Knight's Journey(DFS)
POJ-2488,A Knight's Journey(DFS)
UVA439-骑士的移动 Knight Moves(BFS)
UVA439-骑士的移动 Knight Moves(BFS)
UVA439-骑士的移动 Knight Moves(BFS)
HDOJ/HDU 1372 Knight Moves(经典BFS)
HDOJ/HDU 1372 Knight Moves(经典BFS)
140 0
POJ 1306 Combinations
POJ 1306 Combinations
120 0
|
测试技术
Knight Moves(骑士移动) (bfs) POJ-2243
题目:Knight Moves (骑士移动)

热门文章

最新文章

下一篇
开通oss服务