路由策略配置实战ospf与eigrp的重分布

本文涉及的产品
云数据库 Redis 版,社区版 2GB
推荐场景:
搭建游戏排行榜
简介: 路由策略配置实战

IP地址规划

  • 拓扑中的IP 地址段采用: 172.8.AB.X/24, 其中AB为两台路由器编号组合,例如:R3-R6之间的AB为36,X为路由器编号例如R3的X=3
  • 所有路由器都有一个Loopback0接口,地址格式为: X.X.X.X/32, 其中X为路由器编号。

实验需求

  1. A---F所有区用Loopback 模拟,地址格式为: XX.XX.XX.XX/32, 其中X为路由器编号。根据拓扑宣告进对应协议。A1和A2区为特例,A1: 55.55.55.0/24, A2:55.55.66.0/24。
  2. 按照拓扑图配置EIGRP/OSPF 路由协议,关闭所有自动汇总。OSPF手动指明RID为Loopback 0地址。
  3. R4做双向重分布,R6把OSPF重分布到EIGRP, 要求全网ping 通。如无明确说明,禁止使用静态路由,禁止直接使用ACL过滤数据。
  4. A1区网段为55.55.55.0/24. 配置R6使其禁止从R7学到此网段(要求:使用前缀列表)
  5. 在R4上配置,要求EIGRP重分布到OSPF时,B区Metric 值为100,类型为E1; C区Metric值为200, 类型为E1。 其他路由按照默认设置。
  6. 在R1的Area0中增加以下网段: 11.11.1.0/24、 11.11.2.0/24(用Loopback 模拟),要求在R2上配置最精确的路由汇总,并且只允许在II 区学到该汇总路由。
  7. 要求A1到F区的数据流走R4,A2到E区的数据流走R6(R5带A1和A2的源地址采用Traceroute 测试)
  8. 在R7上配置, 使其路由表中显示去往E、F区的下一跳是R6。
  9. 在R4上配置,使其访问E区走1区-->III 区,其他路线不变(要求:不允许策略路由和分发列表)

案例答案

R1:
interface Loopback0
ip address 1.1.1.1 255.255. 255.255
interface g1/0
ip address 172.8.14.1 255. 255. 255.0
no shutdown
interface g2/0
ip address 172.8.12.1 255. 255. 255.0
no shutdown
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 172.8.12.10.0.0.0 area 0
neteork 172.8.14.1 0.0.0.0 araa 2
interface Loopbackl
ip address 11.11.1. 1 255.255.255.0
ip ospf network point-to-point
interface Loopback2
ip address 11.11.2.1 255.255.255.0
ip ospf network point-to-point 
router ospf 1
network 11.11.1.1 0.0.0.0 area 0
network 11.11.2.1 0.0. 0.0 area 0
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface Loopbackl
ip address 22.22.22.22 255.255.255.255
interface g1/0
ip address 172.8.23.2 255.255.255.0
no shutdown
interface g2/0
ip address 172.8.12.2 255.255.255.0
no shutdown 
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 22.22.22.22 0.0.0.0 area 0
network 172.8.12.2 0.0.0.0 area 0
network 172.8.23.2 0.0.0.0 area 3
router ospf 1
area 0 range 11.11.0.0 255.255.252.0 
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface Loopbackl
ip address 33.33.33.33 255.255.255.255
interface g1/0
ip address 172.8.23.3 255.255.255.0
no shutdown
interface g2/0
ip address 172.8.36.3 255.255.255.0
no shutdown 
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 3 
network 33.33.33.33 0.0.0.0 area 3
network 172.8.23.3 0.0.0.0 area 3 
network 172.8.36.30.0.0.0 area 3 
R4:
interface Loopback0
ip address 4.4.4.4 255.255.255.255
interface Loopback1
ip address 44.44.44.44 255.255.255.255 
interface g1/0
ip address 172.8.14.4 255.255.255.0
no shutdown 
interface g2/0
ip address 172.8.47.4 255.255.255.0
no shutdown
router ospf 1
router-id 4.4.4.4
network 172.8.14.4 0.0.0.0 area 2
router eigrp 1
network 4.4.4.4 0.0.0.0 
network 44.44.44.44 0.0.0.0
network 172.8.47.4 0.0.0.0
no auto-summary
router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1500
router ospf 1
redistribute eigrp 1 subnets
access-list 10 permit 44.44.44.44
access-list 20 permit 66.66.66.66
route-map cisco permit 10
match ip address 10
set metric 100
set metric-type type-1
route -map cisco permit 20
match ip address 20
set metric 200
set metric-type type-1
route-map cisco permit 30
router ospf 100
redistribute eigrp 100 subnets route -map cisco
access-list 30 permit 33.33.33.33
router ospf 100
distance 180 0.0.0.0 255.255.255.255 30
R5:
interface Loopback0
ip address 5.5.5.5 255.255.255.255
interface Loopback1
ip address 55.55.55.55 255.255.255.0
interface Loopback2
ip address 55.55.66.55 255.255.255.0
interface g3/0
ip address 172.8.57.5 255.255.255.0
no shutdown
router eigrp 1
network 5.5.5.5 0.0.0.0
network 55.55.55.1 0.0.0.0
network 55.55.66.2 0.0. 0.0
network 172.8.57.5 0.0.0.0
no auto-summary
R6:
interface Loopback0
ip address 6.6.6.6 255.255.255.255
interface Loopbackl
ip address 66.66.66.66 255.255.255.255
interface g1/0
ip address 172.8.67.6 255.255.255.0
no shutdown 
interface g2/0
ip address 172.8.36.6 255.255.255.0
no shutdown
router ospf 1
router-id 6.6.6.6
network 172.8.36.6 0.0.0.0 area 3
router eigrp 1
network 6.6.6.6 0.0.0.0
network 66.66.66.66 0.0.0.0 
network 172.8.67.6 0.0.0.0
no auto-summary
router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1500
ip prefix-list cisco seq 5 deny 55.55.55.0/24
ip prefix-list cisco seq 10 permit 0.0.0.0/0 le 32
router eigrp 1
distribute-list prefix cisco in g1/0
R6
ip prefix-list ccie seq 5 permit 11.11.0.0/22
route-map ccie deny 10
match ip address prefix-list R1-summary
route-map ccie permit 20
router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1500 route-map ccie
R7:
interface Loopback0
ip address 7. 7.7.7 255. 255. 255.255
interface Loopback1
ip address 77.77. 77.77 255. 255. 255. 255
interface g1/0
ip address 172.8. 67.7 255. 255.255.0
no shutdown 
interface g2/0
ip address 172.8.47.7 255.255.255.0
no shutdown 
interface g3/0
ip address 172.8.57.7 255.255.255.0
no shutdown
router eigrp 1
network 7.7.7.7 0.0.0.0
network 77.77.77.77 0.0.0.0
network 172.8.47.7 0.0.0. 0
network 172.8.57.7 0.0.0.0
network 172.8.67.7 0.0.0.0
no auto-summary
access-list 155 permit ip 55.55.55.0 0.0.0.255 host 22.22.22.22
access-list 156 permit ip 55.55.66.0 0.0.0.255 host 33.33.33.33
route-map CCIE permit 10
match ip address 155
set ip next-hop 172.8.47.4
route-map CCIE permit 20
match ip address 156
set ip next-hop 172.8.67.6 
interface g3/0
ip policy route-map CCIE
access-list 10 permit 22.22.22.22
access-list 10 permit 33.33.33.33
router eigrp 1
offset-list 10 in 100 g2/0
相关实践学习
基于Redis实现在线游戏积分排行榜
本场景将介绍如何基于Redis数据库实现在线游戏中的游戏玩家积分排行榜功能。
云数据库 Redis 版使用教程
云数据库Redis版是兼容Redis协议标准的、提供持久化的内存数据库服务,基于高可靠双机热备架构及可无缝扩展的集群架构,满足高读写性能场景及容量需弹性变配的业务需求。 产品详情:https://www.aliyun.com/product/kvstore     ------------------------------------------------------------------------- 阿里云数据库体验:数据库上云实战 开发者云会免费提供一台带自建MySQL的源数据库 ECS 实例和一台目标数据库 RDS实例。跟着指引,您可以一步步实现将ECS自建数据库迁移到目标数据库RDS。 点击下方链接,领取免费ECS&RDS资源,30分钟完成数据库上云实战!https://developer.aliyun.com/adc/scenario/51eefbd1894e42f6bb9acacadd3f9121?spm=a2c6h.13788135.J_3257954370.9.4ba85f24utseFl
目录
相关文章
|
2天前
|
监控 网络协议 网络架构
|
网络协议 网络架构
|
网络协议 网络架构
|
网络协议 网络架构 数据库